首頁(yè) > 開(kāi)發(fā) > 其他 > 正文

易語(yǔ)言如何實(shí)現定時(shí)關(guān)機和倒計時(shí)關(guān)機(附源碼)

2019-10-20 16:30:58
字體:
來(lái)源:轉載
供稿:網(wǎng)友

本文將為大家講解如何使用易語(yǔ)言實(shí)現定時(shí)關(guān)機和倒計時(shí)關(guān)機,并提供相關(guān)源碼,包括易語(yǔ)言定時(shí)關(guān)機源碼及倒計時(shí)關(guān)機源碼。

打開(kāi)易語(yǔ)言

1、安裝易語(yǔ)言,使易語(yǔ)言軟件可以正常運行及編譯。

2、打開(kāi)易語(yǔ)言。

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

關(guān)機源碼,可2選1使用

1、使用“關(guān)閉系統”命令來(lái)進(jìn)行關(guān)閉。此命令屬于“操作系統界面功能支持庫”

命令源碼:

關(guān)閉系統 (#關(guān)機, 真)

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

2、使用“運行”命令來(lái)調用shutdown.exe實(shí)現關(guān)機。此命令屬于“系統核心支持庫”

命令源碼:

運行 (“shutdown.exe -s -t 0”, 假, )

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

 

定時(shí)關(guān)機源碼

1、在這里使用“運行”的關(guān)機方法來(lái)進(jìn)行演示。

先做界面,6個(gè)編輯框,6個(gè)標簽,一個(gè)按鈕。

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

2、在界面編輯窗口雙擊按鈕進(jìn)入按鈕的單擊事件代碼編寫(xiě)代碼。

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

3、編寫(xiě)代碼。見(jiàn)圖,代碼后有說(shuō)明。

代碼:

.版本 2

.子程序 _按鈕1_被單擊

.局部變量 當前時(shí)間, 日期時(shí)間型, , , 用來(lái)存放點(diǎn)擊按鈕時(shí)的時(shí)間變量

.局部變量 設置時(shí)間, 日期時(shí)間型, , , 用來(lái)存放點(diǎn)在軟件上設置的時(shí)間變量

.局部變量 剩余秒數, 整數型, , , 用來(lái)存放離關(guān)機時(shí)間的秒數

當前時(shí)間 = 取現行時(shí)間 ()

設置時(shí)間 = 到時(shí)間 (編輯框1.內容 + “年” + 編輯框2.內容 + “月” + 編輯框3.內容 + “日” + 編輯框4.內容 + “時(shí)” + 編輯框5.內容 + “分” + 編輯框6.內容 + “秒”)

剩余秒數 = 取時(shí)間間隔 (設置時(shí)間, 當前時(shí)間, #秒)

延時(shí) (剩余秒數 × 1000)

運行 (“shutdown.exe -s -t 0”, 假, )

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

 

倒計時(shí)關(guān)機源碼

1、先做界面,并進(jìn)入代碼編輯窗口。這兩步可見(jiàn)上一步驟同樣的方法。

界面為一個(gè)編輯框,一個(gè)標簽,一個(gè)按鈕

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

2、編寫(xiě)代碼:(注意一下延遲與延時(shí)的區別,用法是一樣的。)

.版本 2

.支持庫 spec

.子程序 _按鈕1_被單擊

.局部變量 剩余秒數, 整數型, , , 用來(lái)存放離關(guān)機時(shí)間的秒數

剩余秒數 = 到整數 (編輯框1.內容)

延遲 (剩余秒數 × 1000)

運行 (“shutdown.exe -s -t 0”, 假, )

易語(yǔ)言,定時(shí)關(guān)機,倒計時(shí)關(guān)機,源碼

 

注意事項

易語(yǔ)言在未購買(mǎi)正式版的時(shí)候可以編譯,但是不能生成EXE

延時(shí)() 與 延遲() 命令的用法。


注:相關(guān)教程知識閱讀請移步到易語(yǔ)言教程頻道。
發(fā)表評論 共有條評論
用戶(hù)名: 密碼:
驗證碼: 匿名發(fā)表